#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-z\d](?:[a-z\d_-]*[a-z\d])?$"
Local $sString = "my-new_page" & @CRLF & _
"pagename" & @CRLF & _
"" & @CRLF & _
"-my-new-page" & @CRLF & _
"my-new-page_" & @CRLF & _
"!@#$%^&*()"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")