$re = '/^[a-z\d](?:[a-z\d_-]*[a-z\d])?$/m';
$str = 'my-new_page
pagename
-my-new-page
my-new-page_
!@#$%^&*()';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);