re = /^[a-z\d](?:[a-z\d_-]*[a-z\d])?$/m
str = 'my-new_page
pagename
-my-new-page
my-new-page_
!@#$%^&*()'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end