using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-z\d](?:[a-z\d_-]*[a-z\d])?$";
string input = @"my-new_page
pagename
-my-new-page
my-new-page_
!@#$%^&*()";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}