using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\]\s(.*?)\s*-{0,1}\s*\d{2}.*?$";
string input = @"[Coalgirls] Mawaru Penguindrum 11 (1280x720_Blu-ray_FLAC)
[FFF] Saenai Heroine no Sodatekata - 04 [BD][720p-AAC][28020890]
[HorribleSubs] OverLord - 01 [720p]
[HorribleSubs] The World God Only Knows - 11 [720p]
[Doki] Zero no Tsukaima - F - 05 (1280x720 Hi10P BD FLAC) [6EE7D53B]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}