const regex = new RegExp('\\]\\s(.*?)\\s*-{0,1}\\s*\\d{2}.*?$', 'gm')
const str = `[Coalgirls] Mawaru Penguindrum 11 (1280x720_Blu-ray_FLAC)
[FFF] Saenai Heroine no Sodatekata - 04 [BD][720p-AAC][28020890]
[HorribleSubs] OverLord - 01 [720p]
[HorribleSubs] The World God Only Knows - 11 [720p]
[Doki] Zero no Tsukaima - F - 05 (1280x720 Hi10P BD FLAC) [6EE7D53B]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}