import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\]\\s(.*?)\\s*-{0,1}\\s*\\d{2}.*?$";
final String string = "[Coalgirls] Mawaru Penguindrum 11 (1280x720_Blu-ray_FLAC)\n\n"
+ "[FFF] Saenai Heroine no Sodatekata - 04 [BD][720p-AAC][28020890]\n\n"
+ "[HorribleSubs] OverLord - 01 [720p]\n\n"
+ "[HorribleSubs] The World God Only Knows - 11 [720p]\n\n"
+ "[Doki] Zero no Tsukaima - F - 05 (1280x720 Hi10P BD FLAC) [6EE7D53B]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}