# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\]\s(.*?)\s*-{0,1}\s*\d{2}.*?$"
test_str = ("[Coalgirls] Mawaru Penguindrum 11 (1280x720_Blu-ray_FLAC)\n\n"
"[FFF] Saenai Heroine no Sodatekata - 04 [BD][720p-AAC][28020890]\n\n"
"[HorribleSubs] OverLord - 01 [720p]\n\n"
"[HorribleSubs] The World God Only Knows - 11 [720p]\n\n"
"[Doki] Zero no Tsukaima - F - 05 (1280x720 Hi10P BD FLAC) [6EE7D53B]")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.