using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\-?\d*\.?\d+[\+\-÷%x]\-?\d*\.?\d+";
string input = @"-3x-4.9-.50.9÷-0.960.9%.8";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}