package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\-?\d*\.?\d+[\+\-÷%x]\-?\d*\.?\d+`)
var str = `-3x-4.9-.50.9÷-0.960.9%.8`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}