$re = '/\-?\d*\.?\d+[\+\-÷%x]\-?\d*\.?\d+/';
$str = '-3x-4.9-.50.9÷-0.960.9%.8';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);