// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\-?\d*\.?\d+[\+\-÷%x]\-?\d*\.?\d+").unwrap();
let string = "-3x-4.9-.50.9÷-0.960.9%.8";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}