import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d*\\.\\d*|\\d*|x_\\{\\d*\\}|\\(.*?\\)+)[\\/]+(\\(.*?\\)|x_\\{\\d*\\}|\\d*\\.\\d*|\\d*)";
final String string = "311/3-31.2/3+x_{3}/4+(3+4)/2+(x_{12}/2+234)/1+9/(3+8)+(5+9/8)/5.6+x_{8}/x_{7}+(3)/m";
final String subst = "\\\\frac{$1}{$2}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}