const regex = /(\d*\.\d*|\d*|x_{\d*}|\(.*?\)+)[\/]+(\(.*?\)|x_{\d*}|\d*\.\d*|\d*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d*\\.\\d*|\\d*|x_{\\d*}|\\(.*?\\)+)[\\\/]+(\\(.*?\\)|x_{\\d*}|\\d*\\.\\d*|\\d*)', 'g')
const str = `311/3-31.2/3+x_{3}/4+(3+4)/2+(x_{12}/2+234)/1+9/(3+8)+(5+9/8)/5.6+x_{8}/x_{7}+(3)/m`;
const subst = `\\frac{$1}{$2}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);