#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.*?<img[^>]*>(<\/?\w+[^>]*>)* +\S).*"
Local $sString = "Hello <img /> world!" & @CRLF & _
"<span>Hello <img /></span> world!" & @CRLF & _
"<span>Hello <img /> </span>world!" & @CRLF & _
"" & @CRLF & _
"Hello <img />!" & @CRLF & _
"<span>Hello <img /></span>!"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")