package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*?<img[^>]*>(<\/?\w+[^>]*>)* +\S).*`)
var str = `Hello <img /> world!
<span>Hello <img /></span> world!
<span>Hello <img /> </span>world!
Hello <img />!
<span>Hello <img /></span>!`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}