const regex = /^(.*?<img[^>]*>(<\/?\w+[^>]*>)* +\S).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*?<img[^>]*>(<\\\/?\\w+[^>]*>)* +\\S).*', 'gm')
const str = `Hello <img /> world!
<span>Hello <img /></span> world!
<span>Hello <img /> </span>world!
Hello <img />!
<span>Hello <img /></span>!`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}