$re = '/^(.*?<img[^>]*>(<\/?\w+[^>]*>)* +\S).*/m';
$str = 'Hello <img /> world!
<span>Hello <img /></span> world!
<span>Hello <img /> </span>world!
Hello <img />!
<span>Hello <img /></span>!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);