import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\d)(\\d{6})(?!\\d)";
final String string = "abc12345 - no match, less than 6 consecutive digits\n\n"
+ "abc123456 - i need to match only this string and return 123456\n\n"
+ "abc1234567 - no match, more than 6 consecutive digits\n\n"
+ "abc12345678 - no match, morethan 6 consecutive digits";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}