re = /(?<!\d)(\d{6})(?!\d)/m
str = 'abc12345 - no match, less than 6 consecutive digits
abc123456 - i need to match only this string and return 123456
abc1234567 - no match, more than 6 consecutive digits
abc12345678 - no match, morethan 6 consecutive digits'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end