use strict;
my $str = 'abc12345 - no match, less than 6 consecutive digits
abc123456 - i need to match only this string and return 123456
abc1234567 - no match, more than 6 consecutive digits
abc12345678 - no match, morethan 6 consecutive digits';
my $regex = qr/(?<!\d)(\d{6})(?!\d)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}