import re
regex = re.compile(r"(?<!\d)(\d{6})(?!\d)", flags=re.MULTILINE)
test_str = ("abc12345 - no match, less than 6 consecutive digits\n\n"
"abc123456 - i need to match only this string and return 123456\n\n"
"abc1234567 - no match, more than 6 consecutive digits\n\n"
"abc12345678 - no match, morethan 6 consecutive digits")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")