#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?=.*\bdog\b)(?=.*\bcat\b).*|cat|dog)$"
Local $sString = "dog cat" & @CRLF & _
"cat dog" & @CRLF & _
"dog" & @CRLF & _
"cat" & @CRLF & _
"dog cata" & @CRLF & _
"cat fish"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")