using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?=.*\bdog\b)(?=.*\bcat\b).*|cat|dog)$";
string input = @"dog cat
cat dog
dog
cat
dog cata
cat fish";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}