re = /^(?:(?=.*\bdog\b)(?=.*\bcat\b).*|cat|dog)$/m
str = 'dog cat
cat dog
dog
cat
dog cata
cat fish'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end