$re = '/^(?:(?=.*\bdog\b)(?=.*\bcat\b).*|cat|dog)$/m';
$str = 'dog cat
cat dog
dog
cat
dog cata
cat fish';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);