#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:(?:(^ *-? +)|(\d+ +cases?)|(Product\w+)|(\d{4})|(\$[\d,.]+)|(Warehouse +\w+)|(-[^-\n]+(?:-|$)))(?: +(?:of|at|in) +| +)?)+"
Local $sString = " - 1 case of ProductA 2020 at $123,456.00 in Warehouse A" & @CRLF & _
" - 2 cases of ProductB 2025 at $123,456.00 in Warehouse B - optional remark" & @CRLF & _
" - ProductC - optional remark - 3 cases at $987,654.00 in 2050 in Warehouse C"
Local $sSubst = "\2\t\3\t\4\t\5\t\6\t\7"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)