const regex = new RegExp('(?:(?:(^ *-? +)|(\\d+ +cases?)|(Product\\w+)|(\\d{4})|(\\$[\\d,.]+)|(Warehouse +\\w+)|(-[^-\\n]+(?:-|$)))(?: +(?:of|at|in) +| +)?)+', 'gm')
const str = ` - 1 case of ProductA 2020 at \$123,456.00 in Warehouse A
- 2 cases of ProductB 2025 at \$123,456.00 in Warehouse B - optional remark
- ProductC - optional remark - 3 cases at \$987,654.00 in 2050 in Warehouse C`;
const subst = `\2\t\3\t\4\t\5\t\6\t\7`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);