// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:(?:(^ *-? +)|(\d+ +cases?)|(Product\w+)|(\d{4})|(\$[\d,.]+)|(Warehouse +\w+)|(-[^-\n]+(?:-|$)))(?: +(?:of|at|in) +| +)?)+").unwrap();
let string = " - 1 case of ProductA 2020 at $123,456.00 in Warehouse A
- 2 cases of ProductB 2025 at $123,456.00 in Warehouse B - optional remark
- ProductC - optional remark - 3 cases at $987,654.00 in 2050 in Warehouse C";
let substitution = "\\2\\t\\3\\t\\4\\t\\5\\t\\6\\t\\7";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}