package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Phone:\s*(\d[-\d]+)`)
var str = `more text
Phone: 123-567-345 more text
more text`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}