$re = '/Phone:\s*(\d[-\d]+)/m';
$str = 'more text
Phone: 123-567-345 more text
more text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);