re = /Phone:\s*(\d[-\d]+)/m
str = 'more text
Phone: 123-567-345 more text
more text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end