using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"&?ordem=(\d+)?([A-Z]+)?";
string substitution = @"";
string input = @"pagina.php?campo=teste&ordem=2&cor=azul
pagina.php?ordem=2&campo=teste
pagina.php?ordem=2FFF&campo=teste
pagina.php?ordem=FFF&campo=teste
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}