use strict;
my $str = 'pagina.php?campo=teste&ordem=2&cor=azul
pagina.php?ordem=2&campo=teste
pagina.php?ordem=2FFF&campo=teste
pagina.php?ordem=FFF&campo=teste
';
my $regex = qr/&?ordem=(\d+)?([A-Z]+)?/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";