$re = '/&?ordem=(\d+)?([A-Z]+)?/';
$str = 'pagina.php?campo=teste&ordem=2&cor=azul
pagina.php?ordem=2&campo=teste
pagina.php?ordem=2FFF&campo=teste
pagina.php?ordem=FFF&campo=teste
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;