package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`&?ordem=(\d+)?([A-Z]+)?`)
var str = `pagina.php?campo=teste&ordem=2&cor=azul
pagina.php?ordem=2&campo=teste
pagina.php?ordem=2FFF&campo=teste
pagina.php?ordem=FFF&campo=teste
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}