const regex = /^(?:feature)\/[A-Z0-9]+\/\w{1,10}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:feature)\\\/[A-Z0-9]+\\\/\\w{1,10}$', 'gm')
const str = `feature/DFX37/test
feature/BE21CLOUD/test
feature/BQCLOUD/test
feature/BXC53FB/test
feature/BE21CLOUD-1/test
feature/BQCLOUD-21/test
feature/be21cloud/test`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}