$re = '/^(?:feature)\/[A-Z0-9]+\/\w{1,10}$/m';
$str = 'feature/DFX37/test
feature/BE21CLOUD/test
feature/BQCLOUD/test
feature/BXC53FB/test
feature/BE21CLOUD-1/test
feature/BQCLOUD-21/test
feature/be21cloud/test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);