// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:feature)\/[A-Z0-9]+\/\w{1,10}$").unwrap();
let string = "feature/DFX37/test
feature/BE21CLOUD/test
feature/BQCLOUD/test
feature/BXC53FB/test
feature/BE21CLOUD-1/test
feature/BQCLOUD-21/test
feature/be21cloud/test";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}