import re
regex = re.compile(r"^(?:feature)\/[A-Z0-9]+\/\w{1,10}$", flags=re.MULTILINE)
test_str = ("feature/DFX37/test\n"
"feature/BE21CLOUD/test\n"
"feature/BQCLOUD/test\n"
"feature/BXC53FB/test\n\n"
"feature/BE21CLOUD-1/test\n"
"feature/BQCLOUD-21/test\n"
"feature/be21cloud/test")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")