import re
regex = re.compile(r"(?:(?<!:)\/\/.*|\/\*[\s\S]*?\*\/)(*SKIP)(*F)|while.+?[\s=(]each[\s(]")
test_str = ("// bar bar\n\n"
"while (list($key, $value) = each($_GET))\n\n"
"/* some code\n"
" while (list($key, $value) = each($_GET))\n"
" some code\n"
"*/\n\n"
"while (list($key, $value) = each($_GET))")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")