package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\.(?<exName>[A-Za-z]+)\((?<exVal>[^()]*)\))+$`)
var str = `.Foo().Bar(20).Baz(Hello)
.Foo().Bar(20)k.Baz(Hello)hgjfvg`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}