re = /^(?:\.(?<exName>[A-Za-z]+)\((?<exVal>[^()]*)\))+$/m
str = '.Foo().Bar(20).Baz(Hello)
.Foo().Bar(20)k.Baz(Hello)hgjfvg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end