$re = '/^(?:\.(?<exName>[A-Za-z]+)\((?<exVal>[^()]*)\))+$/m';
$str = '.Foo().Bar(20).Baz(Hello)
.Foo().Bar(20)k.Baz(Hello)hgjfvg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);