#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*g[o0]+gle)[-a-z0-9!@$^&+%=_(){}<>'";:\/.,~`|]+$"
Local $sString = "Allowed:" & @CRLF & _
"" & @CRLF & _
"hello" & @CRLF & _
"helloworld" & @CRLF & _
"helloworld123" & @CRLF & _
"" & @CRLF & _
"Disallowed:" & @CRLF & _
"" & @CRLF & _
"hellogoogle" & @CRLF & _
"google" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")