import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*g[o0]+gle)[-a-z0-9!@$^&+%=_()\\{\\}<>'\";:\\/.,~`|]+$";
final String string = "Allowed:\n\n"
+ "hello\n"
+ "helloworld\n"
+ "helloworld123\n\n"
+ "Disallowed:\n\n"
+ "hellogoogle\n"
+ "google\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}