using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*g[o0]+gle)[-a-z0-9!@$^&+%=_(){}<>'"";:\/.,~`|]+$";
string input = @"Allowed:
hello
helloworld
helloworld123
Disallowed:
hellogoogle
google
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}