$re = '/^(?!.*g[o0]+gle)[-a-z0-9!@$^&+%=_(){}<>\'";:\/.,~`|]+$/m';
$str = 'Allowed:
hello
helloworld
helloworld123
Disallowed:
hellogoogle
google
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);