$re = '/<table class=\"datatable\s\">(.*?)<\/table>/';
$str = '<table class="datatable"><thead><tr><tr></thead></table>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);