re = /<table class=\"datatable\s\">(.*?)<\/table>/
str = '<table class="datatable"><thead><tr><tr></thead></table>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end